Resolved
All reporting data is now being updated normally. The improvements we deployed yesterday improve the reliability and performance of the overall system.
Investigating
As a result of our maintenance work earlier today, the reporting function within Insights is not showing the most recent data. Instead you will see the data from about 2 hours prior to this message being posted (at 10:15am CST). The data is accurate, it is just not showing numbers from the past 2 hours.