All services have been fully restored
All services have been fully restored and all outstanding issues addressed. This includes re-enabling the machine status indicators (AVAILABLE, COMPLETE etc.) in the Machines page of the Web Portal.
We will be conducting a full Root Cause Analysis both of the system issues and our supporting processes. We will share as much information on that as we can via another update on this site. At this time we can report that the issues stemmed from an extraordinary surge in system utilization over the past 2-3 weeks, and we have preventative measures in place to ensure that this doesn't reoccur as we approach this weekend's busy period.
To receive updates directly from this site, click the Subscribe to Updates button in the top right corner of this web page.
We appreciate your patience and understanding as we worked through these issues over the past 4 days. As usual, if you encounter any issues at your location(s), please contact softwaresupport@alliancels.com.
Resolved
All services have been fully restored
All services have been fully restored and all outstanding issues addressed. This includes re-enabling the machine status indicators (AVAILABLE, COMPLETE etc.) in the Machines page of the Web Portal.
We will be conducting a full Root Cause Analysis both of the system issues and our supporting processes. We will share as much information on that as we can via another update on this site. At this time we can report that the issues stemmed from an extraordinary surge in system utilization over the past 2-3 weeks, and we have preventative measures in place to ensure that this doesn't reoccur as we approach this weekend's busy period.
To receive updates directly from this site, click the Subscribe to Updates button in the top right corner of this web page.
We appreciate your patience and understanding as we worked through these issues over the past 4 days. As usual, if you encounter any issues at your location(s), please contact softwaresupport@alliancels.com.
Monitoring
Services should be returning to normal for all users. We will continue to observe system performance and stability closely. Please report any issues to software support.
We will provide a final update once we have confirmed that the issue is fully resolved.
Identified
System performance has improved and no active incidents are being reported. We continue to monitor closely.
Monitoring
As performance issues have re-emerged this afternoon, we have re-enabled the emergency fallback measure to protect the customer vending experience. Customer vending should be stable, but real-time machine statuses in the Owner Web App owner portal features are temporarily limited.
Our engineering team is now focused on deploying a permanent fix to remove dependencies on the third-party services causing this instability. We will provide updates as we progress on this permanent solution.
Monitoring
Following a period of stability overnight, we are seeing a new increase in support tickets this morning related to the weekend's issues. While the overall impact is currently minimal, our teams are actively investigating these renewed reports.
We are continuing to monitor the situation closely.
Monitoring
Services have remained stable, and platform performance is back to normal. Customer vending and owner portals are operating as expected.
Our team will continue to monitor the platform closely overnight to ensure the issue is fully resolved.
Monitoring
As peak weekend traffic has subsided and platform stability has improved, we have removed the emergency fallback measure. All systems, including real-time machine statuses in the Owner Web App, are being restored.
We are continuing to closely monitor all services to ensure stability is maintained.
Monitoring
As service degradation has continued, we have implemented an emergency fallback measure to protect the core user experience. This action prioritizes customer vending by temporarily limiting some real-time data features in the owner/admin portal.
Customer vending should now be stable. Owners will notice that their Owner Web app will not show live machine statuses. The Mobile App should be unaffected; this is an expected side effect of this mitigation. We continue to monitor the situation.
Monitoring
We have deployed several initial changes to address the issue. These have improved the situation for many locations, but service is not yet fully restored, and some customers may still experience intermittent problems.
We are now monitoring the platform's stability and the effectiveness of these initial fixes. Our team continues to work towards a complete resolution.
Identified
After several hours of investigation, we have identified the root cause of the service disruption. The issue is related to performance degradation from two critical third-party services, which is being exacerbated by unusually high system load.
Our team is now actively working on a fix to mitigate the impact of the external service and restore stability.
Identified
We are currently investigating reports of an issue affecting our digital platform. Customers may be experiencing intermittent vending failures, inaccurate machine statuses, or difficulty selecting cycles.
Our engineering team has been alerted and is actively working to identify the root cause. We apologize for the disruption and will provide another update as we have more information.